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GETTING STARTED GUIDE

NI Signal Generators
This document explains how to install, configure, and test National 
Instruments signal generators to generate various waveforms. This document 
applies to the NI 5401, NI 5404, NI 5411, NI 5421, and NI 5431.

For more information about your device, such as features and programming, 
refer to the NI Signal Generators Help at Start»Programs»National 
Instruments»NI-FGEN»Documents»NI Signal Generators Help.

For your NI signal generator specifications, refer to the specifications 
document included with the device.

For free downloads of the most current versions of documentation, 
visit ni.com/manuals. For the most current example programs, visit 
ni.com/instruments. For the latest version of NI-FGEN, visit 
ni.com/idnet.
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Conventions
The following conventions are used in this manual:

» The » symbol leads you through nested menu items 
and dialog box options to a final action. The sequence 
File»Page Setup»Options directs you to pull down the File 
menu, select the Page Setup item, and select Options from 
the last dialog box.

♦ The ♦ symbol indicates that the following text applies only 
to a specific product, a specific operating system, or a 
specific software version.

This icon denotes a tip, which alerts you to advisory 
information.

This icon denotes a note, which alerts you to important 
information.

This icon denotes a caution, which advises you of 
precautions to take to avoid injury, data loss, or a 
system crash. When this symbol is marked on the hardware 
product, refer to the Safety and Radio-Frequency 
Interference Read Me First, included with the device, 
for precautions to take.

bold Bold text denotes items that you must select or click in the 
software, such as menu items and dialog box options.

device Refers to an NI PXI/PCI-5401, NI PXI-5404, 
NI PXI/PCI-5411, NI PXI/PCI-5421, or NI PXI/PCI-5431.
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italic Italic text denotes emphasis or a cross reference.

monospace Text in this font denotes text or characters that you should 
enter from the keyboard, sections of code, programming 
examples, and syntax examples. This font is also used for 
disk drives, paths, directories, filenames and extensions, 
and functions.

monospace Italic text in this font denotes text that is a placeholder for a
italic word or value that you must supply.

NI signal Refers to an NI PXI/PCI-5401, NI PXI-5404,
generator(s) NI PXI/PCI-5411, NI PXI/PCI-5421, or NI PXI/PCI-5431.

1. Verifying System Requirements
To use your NI signal generator and NI-FGEN, your system needs to meet 
the listed Minimum System Requirements and to have one of the listed 
operating systems installed. For optimal performance, your system should 
meet the Recommended System Requirements. If you are developing 
applications, you need one of the listed Application Development 
Environments (ADEs) along with its documentation.

Minimum System Requirements
• Processor—Pentium 200 MHz or equivalent

• RAM—64 MB

• Microsoft Internet Explorer 5.5 or later

• A screen resolution of 640 × 480 with 256 colors—required for the 
FGEN Soft Front Panel (SFP)

• One of the following operating systems:

– Windows 2000

– Windows NT 4.0 SP6A

– Windows XP

– Windows Me

– Windows 98 SE

• NI Video Generator Wizard only—LabVIEW Run-Time Engine 5.1
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Recommended System Requirements
• Processor—Pentium III/Celeron 600 MHz or equivalent

• RAM—256 MB

• Microsoft Internet Explorer 5.5 or later

• A screen resolution of 640 × 480 with 256 colors—required for the 
FGEN SFP

Application Development Environments
• LabVIEW 6.1 or later

• LabWindows™/CVI™ 5.5 or later

• Measurement Studio 6.0 or later

• Microsoft Visual C++ (MSVC) 6.0 or later

• Microsoft Visual Basic 6.0

• Borland-compliant C compilers

2. Unpacking
NI signal generators ship in an antistatic package to prevent electrostatic 
damage. Electrostatic discharge (ESD) can damage several components 
on the device.

Caution Never touch the exposed pins of connectors.

To avoid damage in handling the device, take the following precautions:

• Ground yourself using a grounding strap or by touching a grounded 
object.

• Touch the antistatic package to a metal part of your computer chassis 
before removing the device from the package.

Remove the device from the package and inspect it for loose components or 
any sign of damage. Notify NI if the device appears damaged in any way. 
Do not install a damaged device into your computer.

Store the device in the antistatic envelope when not in use.
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3. Verifying the Kit Contents
The following items are included in your NI signal generator kit:

❑ Your signal generator 

❑ NI-FGEN case, which contains the following:

– NI-FGEN CD

– NI Signal Generators Getting Started Guide

– NI-FGEN Instrument Driver Quick Reference

❑ Other included documents:

– The specifications document for your signal generator

– Safety and Radio-Frequency Interference Read Me First

– NI 5421 only—Maintain Forced-Air Cooling Note to Users 

❑ NI 5431 only

– NI Composite Video Generator CD

– NI 5431 Video Generator Instrument Driver Quick Reference Guide

Other Required Items
In addition to the items contained in the kit, you need the following:

❑ 1/8 in. flathead screwdriver

❑ Cables appropriate for use with your device

❑ For PXI devices—A PXI chassis, a PXI/SCXI combination chassis, 
or a PXI/CompactPCI chassis—with a controller and the chassis 
documentation

Note If your application uses NI-TClk synchronization, you must 
use a PXI chassis. You cannot use a CompactPCI chassis that is not 
also a PXI chassis. Refer to NI Signal Generators Help»
Programming»NI-TClk Synchronization Help for more 
information.

OR

❑ For PCI devices—A desktop computer with its documentation
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4. Installing the Software
The NI-FGEN CD, included with your device, installs the instrument driver 
for all NI signal generators. Also included on the NI-FGEN CD is the 
FGEN SFP, which is a fast, easy, and interactive tool that helps you to start 
working with the NI signal generator quickly.

To install NI-FGEN, complete the following steps: 

1. (Optional) Install an ADE, such as NI LabVIEW or LabWindows/CVI, 
if you are developing an application for the NI signal generator.

2. Insert the NI-FGEN CD into the CD drive, and follow the instructions in 
the installation window.

Note If the installation window does not appear, navigate to the 
CD drive, double-click the drive, and double-click setup.exe.

♦ For NI 5431 devices only, complete the following steps:

3. Insert the NI Composite Video Generator CD into the CD drive. 

4. Click Install in the installation window that appears, and follow the 
instructions in the dialog boxes.

5. Installing the Hardware
To prevent damage to the device caused by ESD or contamination, handle 
the device using the edges or the metal bracket. Refer to the Safety and 
Radio-Frequency Interference Read Me First for more information.

♦ NI 5421 only—To ensure optimal forced-air cooling, refer to the 
guidelines in the Maintain Forced-Air Cooling Note to Users included 
in the NI signal generator kit.

PXI Installation
To install the device in either a PXI chassis, a PXI/SCXI combination chassis, 
or a PXI/CompactPCI chassis, complete the following steps:

1. Verify that NI-FGEN is installed.

2. Power off and unplug the PXI chassis.

3. Insert the device into an available PXI slot as shown in Figure 1 until the 
ejector handle locks in the up position, and tighten the captive screw(s).
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Figure 1.  PXI Installation

4. Verify that the PXI chassis fans are operable and free of dust and other 
contaminants restricting airflow.

5. Plug in and power on the PXI chassis.

NI PXI-5421 Cooling Considerations

Caution When installing the NI PXI-5421, follow the guidelines 
in the Maintain Forced-Air Cooling Note to Users included in the 
NI 5421 kit to ensure that the device is cooled effectively. If the 
device temperature rises above the optimal operating temperature, 
it shuts down and Measurement & Automation Explorer (MAX) or 
NI-FGEN notifies you with an error message. 

To re-enable the device after thermal shutdown, you must perform a hard 
reset, using one of the following methods:

• Power down the chassis that contains the device.

OR

• Call niFgen_resetDevice (niFgen Reset Device VI) or perform a 
device reset in MAX. For more information on resetting a device in 

1 PXI Chassis
2 NI PXI Device

3 Captive Screws
4 Ejector Handle

8

7

6

5

4

3

2

1

ON

STANDBY

1

2

3

4



NI Signal Generators Getting Started Guide 8 ni.com

MAX, go to Help»Help Topics»NI-DAQmx»Measurement 
& Automation Explorer Help NI-DAQmx, which is available 
within MAX.

Review the guidelines in the Maintain Forced-Air Cooling Note to Users 
and make any necessary adjustments. The thermal shutdown error is reported 
until the device is successfully reset.

Uninstalling PXI Devices
When removing PXI devices from the chassis, ensure that you are grounded 
with a grounding strap or are touching a grounded metal surface. To avoid 
ESD, do not touch the exposed connector pins or any exposed circuitry on the 
device. When not in use, PXI devices should be stored in the original 
packaging to avoid damage. 

Caution During operation, the metal surfaces of PXI devices may 
become hot. Be careful when removing the device from the chassis 
or when moving it to a different peripheral slot. When removing the 
device, hold it by the ejector handle and front panel only. 

PCI Installation
To install the device, complete the following steps:

1. Verify that NI-FGEN is installed.

2. Power off and unplug the PC.

3. Remove the PC cover.
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4. Insert the device into an open PCI slot as shown in Figure 2

Figure 2.  PCI Installation

Tip To maximize airflow and extend the life of the device, leave 
any adjacent PCI slots empty.

5. Secure the device with a screw.

Caution It is important to completely screw the device into the PCI 
slot both for mechanical stability and to create a solid ground 
connection, which will reduce noise. Improperly secured devices 
may affect the accuracy of device specifications.

(NI PCI-5421 only) Some computer manufacturers use a securing 
lever made of plastic to secure PCI devices; such a lever is 
unacceptable and must be removed. Use the screw provided in the kit 
to screw down the NI PCI-5421. Otherwise, you must use a different 
computer chassis.
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6. Replace the PC cover.

7. Plug in and power on the PC.

8. (NI PCI-5421 only) Verify that spread-spectrum clocking is enabled in 
the PC BIOS. Refer to the PC user documentation for information about 
how to verify this setting.

Caution Spread-spectrum clocking varies the clock signal to 
spread the timing clock signal over a small frequency range. 
Disabling spread-spectrum clocking may affect the accuracy 
of the NI PCI-5421 specifications.

NI PCI-5421 Cooling Considerations

Caution When installing the NI PCI-5421, follow the guidelines 
in the Maintain Forced-Air Cooling Note to Users included in the 
NI 5421 kit to ensure that the device is cooled effectively. If the 
device temperature rises above the optimal operating temperature, 
it shuts down and MAX or NI-FGEN notifies you with an error 
message. 

To re-enable the device after thermal shutdown, you must perform a hard 
reset, using one of the following methods:

• Power down the chassis that contains the device.

OR

• Call niFgen_resetDevice (niFgen Reset Device VI) or perform 
a device reset in MAX. For more information on resetting a device 
in MAX, go to Help»Help Topics»NI-DAQmx»Measurement & 
Automation Explorer Help NI-DAQmx, which is available within 
MAX.

Review the guidelines in the Maintain Forced-Air Cooling Note to Users 
and make any necessary adjustments. The thermal shutdown error is reported 
until the device is successfully reset.
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6. Configuring and Testing in MAX
To configure and test your device, complete the following steps:

1. Launch MAX.

2. Double-click Devices and Interfaces to see the list of installed devices. 
MAX automatically detects the installed device. The configuration tree 
lists both Traditional NI-DAQ devices and NI-DAQmx devices, as shown 
in Figure 3.

 

Figure 3.  MAX Configuration Tree

Note If you do not see the device listed, press <F5> to refresh. If 
the device is still not listed, repeat the steps in section 5. Installing 
the Hardware. For more information about using MAX, refer to the 
available help files within MAX.

3. Right-click your NI signal generator in the list, and select Properties to 
launch the Configuring Device window. 

4. Record the device number or device name assigned to the device. You 
need this number when programming your device.

♦ Traditional NI-DAQ (NI 5401/5404/5411/5431)—Select your 
device to see its properties in the configuration view. The 
device number appears in the Value column. When developing 
your application, the resource name for your device is DAQ::n, 
where n is the device number MAX assigned to your device.
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♦ NI-DAQmx (NI 5421)—The assigned device name is appended 
to the device in its configuration tree label. For example, after 
installing the NI 5421, the device configuration tree label may appear 
as NI PXI-5421: "Dev1", where Dev1 is the device name. When 
developing your application, the resource name for your device is the 
device name MAX assigned to the device.

Note To avoid modifying existing applications that use a 
Traditional NI-DAQ device number, change the assigned 
NI-DAQmx device name. To change an NI-DAQmx device name, 
right-click the device, select Rename, and enter the Traditional 
NI-DAQ device number used in your application. For more 
information about device naming conventions, refer to the 
niFgen_init function at NI Signal Generators Help» 
Programming»NI-FGEN Help»NI-FGEN C Function 
Reference Help. 

5. Perform a device self-test to verify installation.

♦ Traditional NI-DAQ—Right-click the device, select Properties, 
and click Test Resources.

♦ NI-DAQmx—Right-click the device and select Self-Test.

A dialog box appears and indicates whether the device passed the test.

Note If the device does not pass the test, repeat the steps in section 
5. Installing the Hardware. If the device still does not pass the test, 
visit NI Technical Support at ni.com/support.

Note If you are using the MXI-3 interface to control the PXI 
chassis, the MXI-3 Optimization Application must be run prior 
to using the NI signal generator. By default, this application runs 
automatically when Windows starts. If you have an initialization 
or performance issue with your module, or if you are not certain 
that the application ran, select Start»Programs»National 
Instruments MXI-3»MXI-3 Optimization to run the application. 
If you continue to have initialization or performance issues, refer 
to the MXI-3 documentation at Start»Programs»National 
Instruments MXI-3, or visit NI Technical Support at 
ni.com/support.

6. Click Close when you have finished testing the device. 

7. Click OK in the Configuring Device window.

8. Exit MAX.
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Synchronizing NI-DAQmx Devices in MAX

Note The following step is required for any type of 
synchronization involving an NI-DAQmx device, including 
NI-TClk synchronization. For information about NI-TClk 
synchronization, refer to NI Signal Generators Help»
Programming»NI-TClk Synchronization Help.

If you plan to share triggers, and/or clocks for the purpose of synchronizing 
NI-DAQmx devices (for example, the NI 5421), you must identify or 
configure certain components in MAX.

♦ For PXI devices, you must identify the PXI system controller by 
completing the following steps:

1. In the MAX configuration tree under Devices and Interfaces, 
right-click PXI System»Identify As and select your controller from 
the list. For example, select External PC if you are using MXI-3 
controller in an external PC. 

2. Expand the PXI System tree and right-click the name of the chassis 
to identify the chassis you are using.

♦ For PCI devices, you must configure the RTSI cable by completing the 
following steps:

1. Connect a RTSI cable between the PCI devices to physically share 
triggers and/or clocks.

2. In the MAX configuration tree under Devices and Interfaces, 
right-click NI-DAQmx Devices.

3. Select Create New NI-DAQmx Device»RTSI Cable.

7. Generating Waveforms
To programmatically generate waveforms, use NI-FGEN. Refer to the 
NI Signal Generators Help for more information about using NI-FGEN 
to generate waveforms.

To interactively generate waveforms, use the FGEN SFP.

♦ NI 5431—In addition to generating waveforms with the NI 5431, you can 
also generate video signals using the NI Video Generator Wizard. To 
generate a video signal with the NI 5431, complete the steps in the 
Generating a Video Signal with the NI 5431 section of this document.
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Generating a Standard Waveform
♦ NI 5401/5404/5411/5431—To generate a standard waveform, complete 

the following steps:

1. Launch MAX.

2. Verify that the device you want to test appears under Devices and 
Interfaces.

Note If the device is not in the Devices and Interfaces list, press 
<F5> to refresh. If the device is still not in the list, repeat the steps 
in section 6. Configuring and Testing in MAX.

3. Launch the FGEN SFP by one of the following methods:

• Select Start»Programs»National Instruments»NI-FGEN»FGEN 
Soft Front Panel.

• Select Tools»Soft Front Panels»NI-FGEN Soft Front Panel from 
the menu bar in MAX.

4. Verify that the device appears on the FGEN SFP display, as shown in 
Figure 4. 

Figure 4.  FGEN SFP Display with the NI PXI-5411 Selected

Note If the device is not listed, or if you have more than one type 
of NI signal generator installed, select Edit»Device Configuration. 
In the Device Configuration dialog box, shown in Figure 5, click 
the Device drop-down listbox arrow, and select the device from the 
list. Click OK to close the Device Configuration dialog box.
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Figure 5.  Device Configuration Dialog Box

5. Verify that the Standard Function mode button  is selected.

6. Select the frequency, amplitude, offset, and type of waveform that you 
want to generate. 

7. Click the run button  to initiate waveform generation. 

The FGEN SFP default settings instruct the NI 5401/5404/5411/5431 
to generate a continuous sine wave at a frequency of 1 MHz, with a 
peak-to-peak amplitude of 1 V into a 50 Ω load, and no offset. Adjust the 
sine waveform settings in the FGEN SFP to match your needs. For more 
information about the FGEN SFP, select Help»FGEN SFP Help or 
Help»Show Context Help. For device-specific help, select 
Help»Hardware-Specific Help.

Generating an Arbitrary Waveform
♦ NI 5411/5421/5431—To generate an arbitrary waveform with your 

device, complete the following steps:

1. Launch MAX.

2. Verify that the device you want to test appears under Devices and 
Interfaces.

Note If the device is not listed under Devices and Interfaces, 
press <F5> to refresh. If the device is still not listed, repeat 
the steps in section 6. Configuring and Testing in MAX.

3. Select Start»Programs»National Instruments»NI-FGEN»FGEN 
Soft Front Panel.
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4. Verify that the device you installed appears on the FGEN SFP display, 
as shown in Figure 6.

♦ NI 5411/5431—Verify that the single arbitrary waveform output 
button located in the Mode section is selected, as shown in Figure 6.

Figure 6.  FGEN SFP Display with NI PXI-5421 Selected

♦ NI 5421—The signal arbitrary waveform output button located in the 
Mode section is automatically selected.

Note If the device is not listed, or if you have more than one type 
of NI signal generator installed, select Edit»Device Configuration. 
In the Device Configuration dialog box, shown in Figure 5, click 
the Device drop-down listbox arrow, and select the device from the 
list. Click OK to close the Device Configuration dialog box.

5. To download a waveform to the device onboard memory, click the 
Current Waveform Pattern button, select New Waveform, and click 
Next. The File Load dialog box and Select File window both open. 
The Select File window displays waveform example files.

Note You can also download a waveform by selecting File»Load 
New Waveform and clicking Next. The default location for 
example waveforms is \Program Files\IVI\Drivers\niFgen\
Examples\Waveforms\.

6. Select File and click Next.

7. Select arbMode-sine.lvm and click OK. A preview of the waveform 
launches. You can close or minimize the Waveform Preview window.



© National Instruments Corporation 17 NI Signal Generators Getting Started Guide

8. In the File Load dialog box, select one of the following settings from the 
Waveform drop-down listbox:

♦ NI PXI-5411/5431—sine, 16MHz@40MS/s

♦ NI PXI-5421—sine, 40MHz@100MS/s

9. Click OK.

10. Click the run button  to initiate waveform generation. To optimize 
the sine wave shape, select Edit»Device Configuration, and change the 
filter settings.

The FGEN SFP default settings instruct the NI 5411/5421/5431 to generate 
a continuous sine wave, with a peak-to-peak amplitude of 1 V into a 50 Ω 
load, and no offset. Adjust the sine waveform settings in the FGEN SFP to 
match your needs. For more information about the FGEN SFP, select Help»
FGEN SFP or Help»Show Context Help.

Generating a Video Signal with the NI 5431
To programmatically generate video signals, use the NI Composite Video 
Generator in LabVIEW. For information about programmatically generating 
video signals, refer to the NI 5431 Composite Video Generator Help. Access 
this help file by selecting Help»NI5431 from the LabVIEW VI menu bar.

To interactively generate a video signal using the NI Video Generator 
Wizard, complete the following steps:

1. Launch MAX.

2. Verify that the device you want to test appears under Devices and 
Interfaces.

Note If the device is not listed under Devices and Interfaces, press 
<F5> to refresh. If the device is still not listed, repeat the steps in 
section 6. Configuring and Testing in MAX.

3. Launch the NI Video Generator Wizard, shown in Figure 7, by selecting 
Start»Programs»National Instruments Composite Video 
Generator»Video Generator Wizard.
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Figure 7.  NI Video Generator Wizard

Note To use the NI Video Generator Wizard, the LabVIEW 
Run-Time Engine version 5.1.1 must be installed. You can 
download this software at ni.com/softlib.nsf.

4. Generate a video signal based on a bitmap image using the factory 
settings. Complete the following steps while referring to Figure 7.

a. Verify that the Device ID is set to the correct value—the device 
number previously configured in MAX.

b. Select Load BMP file and compute video data.

c. Click Browse.

d. Double-click the appropriate directory from the following choices:

• For NTSC users, double-click the 640x480 or the 1044x480 
directory.

• For PAL and SECAM users, double-click the 768x576 or the 
1040x576 directory.

Note For information about video data file formats, refer to the 
NI Signal Generators Help.

e. Double-click any of the example .bmp files. The bitmap image file 
path appears in the BMP Input File Path control box.



© National Instruments Corporation 19 NI Signal Generators Getting Started Guide

f. Select Use factory settings. This option applies the default video 
parameters to the video signal you want to generate.

g. Select M-NTSC, Standard-PAL, or SECAM, depending on the 
video format you want to generate.

h. Select Download video data file. This option downloads the binary 
video data from your computer to the NI 5431 device.

Note To display the .bmp file on your computer monitor, enable 
Display BMP.

i. Click Finish. The Processing dialog box appears displaying the 
processing status.

Based on the .bmp file you selected, the NI Video Generator Wizard 
calculates either NTSC, PAL, or SECAM video data, downloads the 
calculated data to the NI 5431 device, and automatically starts generating 
the video signal on the VIDEO OUT connector.

Appendix A: Front Panels
This section contains front panel connector figures and connector description 
tables that describe the signal connection options for NI signal generators.
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NI PXI-5401
The NI PXI-5401 has four connectors—two BNC connectors and two SMB 
connectors, as shown in Figure 8. Signal descriptions are listed in Table 1. 

Figure 8.  NI PXI-5401 Front Panel Connectors

ARB OUT

SYNC OUT

EXT TRIG

PLL REF

LOCK ACCESS

NI PXI-5401
Arbitrary Function Generator
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Table 1.  NI PXI-5401 Connectors

Connector Access Function

ARB OUT Output Provides the waveform output.

SYNC OUT Output Provides a TTL-level output of the waveform 
being generated at the ARB OUT connector.

EXT TRIG Input Accepts a TTL-level signal that you can use to 
start or step through a waveform generation.

PLL REF Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PXI-5401 
internal clock to the external reference clock.



NI Signal Generators Getting Started Guide 22 ni.com

NI PCI-5401
The NI PCI-5401 has four connectors—three SMB connectors and 
one 50-pin digital connector, as shown in Figure 9. Signal descriptions 
are listed in Table 2.

Figure 9.  NI PCI-5401 Front Panel Connectors
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Table 2.  NI PCI-5401 Connectors

Connector Access Function

ARB Output Provides the waveform output.

SYNC Output Provides a TTL-level output of the waveform being 
generated at the ARB OUT connector.

PLL IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PCI-5401 
internal clock to the external reference clock.

PATTERN OUT Input Supplies the external trigger input to the device. 
Refer to the NI Signal Generators Help for 
connector pin assignments and signal descriptions.
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NI PXI-5404
The NI PXI-5404 has five SMB connectors, as shown in Figure 10. Signal 
descriptions are listed in Table 3.

Figure 10.  NI PXI-5404 Front Panel Connectors

SINE

REF
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REF
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PFI 0

CH 0

CLOCK

ACCESS ACTIVE

NI PXI-5404
100 MHz Freq Source
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Table 3.  NI PXI-5404 Connectors

Connector Access Function

SINE Output Provides a sine waveform of the desired frequency 
output.

CLOCK Output Provides a TTL version of the sine waveform 
being generated at the SINE connector.

PFI 0 Input/
Output

Accepts either a TTL signal to start waveform 
generation, or provides an output to 
synchronize—or trigger—other devices at 
a certain time within waveform generation.

REF OUT Output Routes signals from the PXI backplane clock, 
PXI trigger lines, or a divided-down version of 
the internal NI 5404 clock.

REF IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the NI PXI-5404 
internal clock to the external reference clock.
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NI PXI-5411/5431
NI PXI-5411/5431 have six connectors—two BNC connectors, 
three SMB connectors, and one 50-pin digital connector, as shown 
in Figure 11. Signal descriptions are listed in Table 4. 

Figure 11.  NI PXI-5411/5431 Front Panel Connectors
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Table 4.  NI PXI-5411/5431 Connectors

Connector Access Function

ARB OUT/
VIDEO OUT

Output Provides the waveform output.

SYNC OUT Output Provides a TTL-level output of the waveform 
being generated at the ARB OUT connector.

EXT TRIG Input Accepts a TTL-level signal that you can use to start 
or step through a waveform generation.

MARKER OUT Output Sends a TTL-level signal that you can set at any 
point in the waveform being generated. You can 
use this signal to synchronize or trigger other 
devices at a certain time within waveform 
generation.

PLL REF Input Accepts a PLL reference clock from an 
external source and can frequency lock the 
NI PXI-5411/5431 internal clock to the external 
reference clock. You can also use this connector 
as a source of the device sample clock from an 
external device.

DIGITAL 
PATTERN/
VIDEO 
DIGITAL 
PATTERN

Input/
Output

Routes 16-bit digital pattern outputs, digital 
pattern clock output, marker output, external 
trigger input, and +5 V power output. Refer to 
the NI Signal Generators Help for connector pin 
assignments and signal descriptions.
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NI PCI-5411/5431
The NI PCI-5411/5431 have four connectors—three SMB connectors and 
one 50-pin digital connector, as shown in Figure 12. Signal descriptions are 
listed in Table 5.

 

Figure 12.  NI PCI-5411/5431 Front Panel Connectors
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Table 5.  NI PCI-5411/5431 Connectors

Connector Access Function

ARB Output Provides the waveform output.

SYNC Output Provides a TTL-level output of the waveform 
being generated at the ARB OUT connector.

PLL IN Input Accepts a PLL reference clock from an 
external source and can frequency lock the 
NI PCI-5411/5431 internal clock to the external 
reference clock.

PATTERN 
OUT

Input/Output Routes the 16-bit digital pattern outputs, digital 
pattern clock output, marker output, external 
trigger input, and +5 V power output. Refer to 
the NI Signal Generators Help for connector pin 
assignments and signal descriptions.
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NI PXI/PCI-5421
The NI PXI/PCI-5421 has five connectors—four SMB connectors and one 
68-pin male VHDCI connector, as shown in Figure 13. Signal descriptions 
are listed in Table 6.

Figure 13.  NI PXI/PCI-5421 Front Panel Connectors
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Appendix B: Technical Support Resources

NI Web Support
National Instruments Web support is your first stop for help in solving 
installation, configuration, and application problems and questions. Online 
problem-solving and diagnostic resources include frequently asked 
questions, knowledge bases, product-specific troubleshooting wizards, 
manuals, drivers, software updates, and more. Web support is available 
through the Technical Support section of ni.com. 

A Declaration of Conformity (DoC) is our claim of compliance with the 
Council of the European Communities using the manufacturer’s declaration 
of conformity. This system affords the user protection for electronic 
compatibility (EMC) and product safety. You can obtain the DoC for your 
product by visiting ni.com/hardref.nsf. If your product supports 
calibration, you can obtain the calibration certificate for your product at 
ni.com/calibration. 

Table 6.  NI PXI/PCI-5421 Connectors

Connector Access Function

CH 0 Output Provides the waveform output.

CLK IN Input Accepts a PLL reference clock from an external 
source and can frequency lock the 
NI PXI/PCI-5421 internal clock to the external 
reference clock. The signal input onto this 
connector can also be used as a sample clock 
source for the NI 5421.

PFI 0 Input/Output Accepts a trigger from an external source that 
can start or step through waveform generation, 
or can route signals out from several clock, 
event, and trigger sources. Refer to the NI Signal 
Generators Help for signal descriptions and 
routing information.

PFI 1 Input/Output Accepts a trigger from an external source that 
can start or step through waveform generation, 
or can route signals out from several clock, 
event, and trigger sources. Refer to the NI Signal 
Generators Help for signal descriptions and 
routing information.

Digital Data & 
Control (DDC)

Input/Output Routes the 16-bit digital pattern outputs, digital 
pattern clock output, trigger outputs, trigger 
inputs, and a clock input. Refer to the NI Signal 
Generators Help for connector pin assignments 
and signal descriptions.
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Worldwide Support
National Instruments corporate headquarters is located at 11500 North 
Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also 
has offices located around the world to help address your support needs. 
You can access our branch office Web sites from the Worldwide Offices 
section of ni.com. Branch office Web sites provide up-to-date contact 
information, support phone numbers, email addresses, and current events. 

If you have searched the technical support resources on our Web site and still 
cannot find the answers you need, contact your local office or National 
Instruments corporate. For telephone support in the United States, dial 
512 795 8248. For telephone support outside the United States, contact your 
local branch office:

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada (Calgary) 403 274 9391, Canada (Ottawa) 613 233 5949, 
Canada (Québec) 450 510 3055, Canada (Toronto) 905 785 0085, 
Canada (Vancouver) 514 685 7530, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, Greece 30 2 10 42 96 427, 
India 91 80 51190000, Israel 972 0 3 6393737, Italy 39 02 413091, 
Japan 81 3 5472 2970, Korea 82 02 3451 3400, Malaysia 603 9131 0918, 
Mexico 001 800 010 0793, Netherlands 31 0 348 433 466, 
New Zealand 0800 553 322, Norway 47 0 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 095 783 68 51, 
Singapore 65 6226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 2 2528 7227, Thailand 662 992 7519, 
United Kingdom 44 0 1635 523545
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